Office patches suddenly stop reporting on WSUS

Strangely, this did not appear too much in any searches. Consider the following:

  • You have Office patches distributed via WSUS to your network
  • Machines report back they need Windows patches without an issue
  • A very small number, or zero in my case, report back they need Office patches when in fact you are aware there are patches available
  • This started happening after April 2015.

Microsoft have just recently released a post announcing the end of RTM support for Office 2013 as of April 2015. Therefore, unless Office SP1 is installed, no soup for you since April!

Makes sense from a stability and security point of view, but I find it rather odd that it was only announced on June 9.

My test lab is now reporting back, hungry for Office updates. Hope this helps someone.

Exchange 2003 Server uninstall fails with error 0x8000ffff

This is a pesky one. The last step of the decommissioning of an Exchange 2003 server from the Add/Remove Programs option (after correctly removing all per-requisites) and bam- this error pops up on uninstall.

Reason being- the error points to (but does not explain) the installation media path/disk not being able to be found so the uninstall can continue. Now, I’d seen this before with another uninstall but it actually prompted me for a network path for the media (This was Exchange 2003 Std versus Enterprise this time, but really this shouldn’t differ!)

Either:

  • Run the setup from the Exchange media and uninstall this way or
  • Download the media (if you’d lost it like I had) and uninstall as per above.

That worked a treat.